Задать вопрос
3 мая, 21:57

Написать программу

Пользователь вводит число, проверить извлекается ли из это числа корень

+2
Ответы (1)
  1. 3 мая, 23:56
    0
    Var a, b:integer;

    begin

    write ('a = ') ;

    readln (a) ;

    b:=round (sqrt (a)) ;

    if b*b=a

    then writeln ('Yes, ', b,' * ', b,' = ', a)

    else writeln ('No') ;

    end.

    Пример:

    a = 169

    Yes, 13 * 13 = 169
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу Пользователь вводит число, проверить извлекается ли из это числа корень ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы