Задать вопрос
7 декабря, 00:44

Ниже записан алгоритм. Получив на вход число х, этот алгоритм печатает два числа L и M. Укажите наибольшее из таких чисел х, при вводе которых алгоритм печатает сначала 3, а потом 120.

var х, L, M: integer;

begin

readln (x) ;

L: = 0; M : = 1;

while x>0 do

begin

L : = L + 1;

M : = M * (x mod 8) ;

х : = x div 8;

end;

writeln (L) ; write (M) ;

end.

+3
Ответы (1)
  1. 7 декабря, 03:23
    0
    Ответ: 428

    нашел с помощь программы

    var

    x, L, M, i:integer;

    begin

    for i : = 4096 downto 1 do

    begin

    L : = 0;

    M : = 1;

    x : = i;

    while x > 0 do

    begin

    Inc (L) ;

    M : = M * (x mod 8) ;

    x : = x div 8;

    end;

    if (L = 3) and (M = 120) then

    begin

    WriteLn ('x = ', i) ;

    break;

    end;

    end;

    readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Ниже записан алгоритм. Получив на вход число х, этот алгоритм печатает два числа L и M. Укажите наибольшее из таких чисел х, при вводе ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы