Задать вопрос
30 марта, 23:53

Помогите!:с нужно составить алгоритм на языке программирования Паскаль.

Дан массив, состоящий из 10 элементов. Определите, сколько элементов этого массива имеют максимальное значение.

+1
Ответы (1)
  1. 31 марта, 00:03
    0
    Var a:array[1 ... 10] of real;

    b, c:integer;

    max:real;

    begin

    c:=0;

    writeln ('Введите элементы массива') ;

    for b:=1 to 10 do

    begin

    readln (a[b]) ;

    end;

    max:=a[1];

    for b:=1 to 10 do

    begin

    if a[b]>max then max:=a[b];

    end;

    for b:=1 to 10 do

    begin

    if a[b]=max then c:=c+1;

    end;

    writeln ('Количество элементов, имеющих максимальное значение равняется ', c) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите!:с нужно составить алгоритм на языке программирования Паскаль. Дан массив, состоящий из 10 элементов. Определите, сколько ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы