Задать вопрос
9 августа, 13:23

Напишите программу в Паскале, где дано натуральное число n и вычислить произведение первых n-сомножителей:

а) 1*3/2*5/3 ...

б) 1*1/3*1/5 ...

+3
Ответы (1)
  1. 9 августа, 15:17
    0
    Var

    N, i, j:integer;

    P:real;

    Begin

    i:=1;

    j:=1;

    P:=1;

    WriteLn ('Введите число N') ;

    ReadLn (N) ;

    Write ('а: 1') ;

    While in do

    begin

    j:=j+2;

    i:=i+1;

    P:=P * (j/i) ;

    Write ('*', j,'/', i) ;

    end;

    Write ('=', P) ;

    WriteLn () ;

    Write ('б: 1') ;

    i:=1;

    j:=1;

    P:=1;

    While in do

    begin

    j:=j+2;

    i:=i+1;

    P:=P/i;

    Write ('*1/', j) ;

    end;

    Write ('=', P) ;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу в Паскале, где дано натуральное число n и вычислить произведение первых n-сомножителей: а) 1*3/2*5/3 ... б) 1*1/3*1/5 ... ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы