Задать вопрос
16 декабря, 02:33

Приведите примеры неправильного использования div и mod

+4
Ответы (1)
  1. 16 декабря, 03:23
    0
    Не совсем понимаю вопроса.

    div - это целое значения после деления одного числа на другое

    mod - это остаток от деления одного числа на другое

    т. е. например

    a:=7 div 2;

    a=3

    b:=7 mod 2;

    b=1

    Примеры использования div и mod могут быть разные. Например их можно использовать для деления числа на отдельные цифры. Так остаток от деления на 10 (a mod 10) даст нам последнюю цифру. А если для трёхзначного числа зададим (a div 100) то найдём его первую цифру. Так же для нахождения средней цифры в трёхзначном числе можно написать как ((a mod 100) div 10) так и ((a div 10) mod 10).

    Так же с помощью mod можно находить количество цифр в числе, и программа будет выглядеть так:

    var i:byte; a, k:integer;

    a:=4873; k:=0;

    while a>0 do begin

    k:=k+1;

    a:=a mod 10;

    end;

    writeln (k) ;

    end.

    Знаем что такое двоичная система? Так вот с помощью div и mod можно написать программу перевода числа в двоичную систему, или просто подсчитать количество нулей и единиц в двоичной записи числа. Подсчёт единиц и нулей выглядит так:

    var a, b, c:integer;

    a:=34; b:=0; c:=0;

    while a>0 do begin

    if a mod 2=0 then b:=b+1 else c:=c+1;

    a:=a mod 10;

    end;

    writeln ('количество нулей=', b) ;

    writeln ('количество единиц=', c) ;

    end.

    Вообще много чего можно придумать. Узнать чётное ли число (mod), узнать количество чётных и нечётных цифр в числе (mod), узнать сколько раз число a делиться на число b (mod и div).

    Так div и mod можно использовать где угодно и как угодно, и всё зависит от фантазии человека который пишет программу. Единственное что надо помнить, что mod и real выполняются для чисел integer, и если мы попытаемся исполнить операции для real (например 3,4 или 6,7) то наткнёмся на ошибку. Ну а так же, чисто из математики, мы не можем делить на ноль, следственно (a div 0) тоже операция не выполнима так же как и (a mod 0).
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Приведите примеры неправильного использования div и mod ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы