Задать вопрос
22 февраля, 13:20

Помогите 2 задачки сделать на паскале

1) с клавиатуры вводится последовательность чисел до тех пор пока не будет введено число 0. требуется найти количество чисел во введенной последовательности, оканчивающихся на цифру 7.

2) Дано целое число N. Выяснить, есть ли в записи этого числа хотя бы одна пара одинаковых подряд идущих цифр. Например, для числа 3221 - ответ положительный, для числа 121 - ответ отрицательный

+5
Ответы (1)
  1. 22 февраля, 14:28
    0
    1) var i, x:integer;

    begin

    i:=1;

    while i0 do

    begin

    readln (i) ;

    if i mod 10 = 7 then x:=x+1;

    end;

    write (x) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите 2 задачки сделать на паскале 1) с клавиатуры вводится последовательность чисел до тех пор пока не будет введено число 0. требуется ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
С клавиатуры вводится последовательность чисел до тех пор пока не будет введено число 0. требуется найти произведение чисел из введенной последовательности кратных пяти
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
С клавиатуры вводится целое число n. найти произведение всех цифр этого числа а так же колличество больших шестс клавиатуры вводится целое число n. найти произведение всех цифр этого числа а так же колличество больших шестии
Ответы (1)
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)