Задать вопрос
22 сентября, 15:25

Написать программу определения суммы цифр числа и их количества, используя оператор цикла с постусловием.

Программа Паскаль

+4
Ответы (1)
  1. 22 сентября, 18:34
    0
    Program gt;

    var n, q, s, k:integer;

    begin

    read (n) ;

    s:=0;

    k:=0;

    while n>0 do

    begin

    q:=n mod 10;

    n:=n div 10;

    s:=s+q;

    k:=k+1;

    end;

    writeln (s,' ', k) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу определения суммы цифр числа и их количества, используя оператор цикла с постусловием. Программа Паскаль ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы