Задать вопрос
21 октября, 00:35

Напишите программу которая в последовательности целых чисел выбранных случайном образом из диапазона от 15 до 69 определяет разность максимального и минимального чисел

+3
Ответы (1)
  1. 21 октября, 02:38
    0
    Программа без массива:

    const n=10;

    var a, i, max, min:integer;

    begin

    Randomize;

    min:=69; max:=15;

    for i:=1 to n do

    begin

    a:=random (55) + 15;

    write (a,' ') ;

    if a>max then max:=a;

    if a
    end;

    writeln;

    writeln ('max-min = ', max,'-', min,' = ', max-min) ;

    end.

    Пример:

    21 16 40 57 41 63 48 50 54 45

    max-min = 63-16 = 47

    Программа с массивом:

    const n=10;

    var a:array[1 ... n] of integer;

    i, max, min:integer;

    begin

    Randomize;

    for i:=1 to n do

    begin

    a[i]:=random (55) + 15;

    write (a[i],' ') ;

    end;

    writeln;

    min:=a[1]; max:=a[1];

    for i:=2 to n do

    begin

    if a[i]>max then max:=a[i];

    if a[i]
    end;

    writeln ('max-min = ', max,'-', min,' = ', max-min) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу которая в последовательности целых чисел выбранных случайном образом из диапазона от 15 до 69 определяет разность ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы