Задать вопрос
8 июля, 16:19

Помогите решить 2 задачи в паскале:

1) Определить равны ли все цифры заданного пятизначного числа.

2) Каждое число Фибоначчи вычисляется как f1=0, f2=1, а начиная с третьего по формуле fn=fn-1+fn-2. Составить программу, которая вычисляет n чисел Фибоначчи.

+2
Ответы (1)
  1. 8 июля, 17:45
    0
    1.

    Function Check (A : Longint) : Boolean;

    Begin

    If A>9 then Check: = ((A mod 10) = (A div 10 mod 10)) and Check (A div 10) else Check:=True;

    end;

    Var N : Longint;

    Begin

    Readln (N) ;

    Writeln (Check (N)) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите решить 2 задачи в паскале: 1) Определить равны ли все цифры заданного пятизначного числа. 2) Каждое число Фибоначчи вычисляется ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы