Задать вопрос
10 апреля, 07:57

Написать программу формирующую двумерный массив размером 4 х4 и выводящую на экран максимальное количество элементов этого массива

+3
Ответы (1)
  1. 10 апреля, 11:55
    0
    Видимо имеется ввиду выводящий максимальны элемент этого массива

    В данном примере матрица формируется при помощи случайных чисел

    program MatrixMax;

    Uses Crt;

    type matrix=array[1 ... 4,1 ... 4] of real;

    var m:matrix;

    max:real;

    {Порождение матрицы случайным образом}

    procedure Auto;

    var i, j:integer;

    begin

    randomize;

    for i:=1 to 4 do

    begin

    for j:=1 to 4 do

    begin

    m[i, j]:=25+random (21) ;

    end;

    end;

    end;

    {Вывод матрицы на экран}

    procedure PrintMatrix (mas:matrix) ;

    var j, k:integer;

    begin

    for k:=1 to 4 do

    begin

    for j:=1 to 4 do

    begin

    write (mas[k, j]:7:2) ;

    end;

    writeln;

    end;

    end;

    {Нахождение максимального элемента}

    procedure Мax;

    var i, j:integer;

    begin

    max:=m[1,1]

    for i:=1 to 4 do

    begin

    for j:=1 to 4 do

    begin

    if (max
    end;

    end;

    end;

    begin

    Clrscr;

    Auto;

    PrintMatrix;

    Max;

    writeln;

    writeln ('Максимальный элемент матрицы: ', max) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу формирующую двумерный массив размером 4 х4 и выводящую на экран максимальное количество элементов этого массива ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы