Задать вопрос
18 декабря, 04:05

Написать программу:"Дано четырехзначное число. Что больше: сумма цифр, стоящих на четных местах, или сумма цифр, стоящих на не четных местах?"

+3
Ответы (1)
  1. 18 декабря, 06:57
    0
    Var a, s1, s2:integer;

    begin

    read (a) ;

    if (a>=1000) and (a<=9999) then

    begin

    s1: = (a mod 10) + ((a mod 1000) div 100) ;

    s2: = (a div 1000) + ((a mod 100) div 10) ;

    if (s1>s2) then writeln ('Сумма цифр, стоящих на четных местах больше суммы цифр, стоящих на нечетных местах') ;

    if (s1
    if (s1=s2) then writeln ('Сумма цифр, стоящих на четных местах равна сумме цифр, стоящих на нечетных местах') ;

    end

    else writeln ('Вы ввели не 4-ёхзначное число') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу:"Дано четырехзначное число. Что больше: сумма цифр, стоящих на четных местах, или сумма цифр, стоящих на не четных ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы