Задать вопрос
29 ноября, 10:46

Для настольной игры используются карточки с номерами от 1 до N. Одна карточка потерялась. Найдите ее, зная номера оставшихся карточек.

Входные данные

Дано число N, далее N-1 номер оставшихся карточек (различные числа от 1 до N).

Выходные данные

Программа должна вывести номер потерянной карточки.

+3
Ответы (1)
  1. 29 ноября, 12:59
    0
    Var n, i, k, s1, s2:integer;

    begin

    write ('n=') ; readln (n) ;

    s1:=n; s2:=0;

    for i:=1 to n-1 do

    begin

    write ('k', i,'=') ; readln (k) ;

    s1:=s1+i; s2:=s2+k;

    end;

    writeln ('Потерялась карточка ', s1-s2) ;

    end.

    Пример:

    n=5

    k1=1

    k2=3

    k3=4

    k4=5

    Потерялась карточка 2
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Для настольной игры используются карточки с номерами от 1 до N. Одна карточка потерялась. Найдите ее, зная номера оставшихся карточек. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы