Задать вопрос
1 ноября, 04:43

Составьте программу возведения в квадрат всех целых чисел от 0 до 50.

1) использовать цикл с предусловием.

2) использовать цикл с постусловием.

3) использовать цикл с параметром.

+3
Ответы (2)
  1. 1 ноября, 04:51
    0
    2) #include#include #includeusing namespace std; int main () {int c=0, b; do{

    b = pow (c, 2) ; c++; cout << b << " "; } while (c<51) ; system ("pause") ;

    }

    1) #include#include #includeusing namespace std; int main () {int c=0, b;

    while (c<51) {

    b = pow (c, 2) ; c++; cout << b << " "; } system ("pause") ;

    }

    3) #include#include #includeusing namespace std; int main () {int c=0, b;

    for (c; c<51; c++) {

    b = pow (c, 2) ; cout << b << " "; } system ("pause") ;

    }
  2. 1 ноября, 07:31
    0
    Program sqr;

    Var i:integer;

    begin

    while i < = 50 do / / 1)

    begin

    write (i*i, ' ') ;

    Inc (i) ;

    end;

    i:=0;

    writeln;

    repeat / / 2)

    write (i*i, ' ') ;

    Inc (i) ;

    until i > 50;

    writeln;

    for i:=1 to 50 do write (i*i, ' ') ; / / 3)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу возведения в квадрат всех целых чисел от 0 до 50. 1) использовать цикл с предусловием. 2) использовать цикл с ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы