Задать вопрос
6 июля, 20:30

Составить программу в которой записать в массив N номера положительных элементов массива (x1, x2 ... x15)

+4
Ответы (1)
  1. 6 июля, 21:11
    0
    var

    N: array [1 ... 15] of 1 ... 15; {Массив, в который записываются номера положительных элементов массива х}

    x: array [1 ... 15] of real; / / Массив х

    i: integer; / / Переменная для цикла

    Number: integer; / / Сколько номеров было записано

    begin

    Number: = 0; / / Обнуляем счетчик номеров

    for i: = 1 to 15 do / / Вводим с клавиатуры массив х

    begin

    writeln ('Введите ', i, ' элемент массива х') ;

    readln (x[i]) ;

    if x[i] > 0 then {Если введенный элемент массива х положительный, то прибавляем к счетчику добавленных номеров 1 и присваиваем соответствующему элементу массива N номер элемента}

    begin

    Number: = Number + 1;

    N[Number]: = i;

    end;

    end;

    write ('Номера положительных элементов массива х: ') ;

    for i: = 1 to Number do write (n[i], ' ') ; / / Выводим записанные номера элементов

    writeln; {Переход на новую строку, чтобы при следующем запуске программы информация выводилась с новой строки}

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу в которой записать в массив N номера положительных элементов массива (x1, x2 ... x15) ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы