Задать вопрос
4 марта, 00:12

Напишите программу. Группа студентов сдает экзамен. оценки формируются случайным образом от 2 до 5. Напечатать кол-во полученых двок, трок, четверок, пятерок

+1
Ответы (1)
  1. 4 марта, 01:42
    0
    Pascal

    const n = 10; / / Кол-во студентов

    //можно сделать с вводом с клавиатуры

    var i, a : integer;

    o : array[2 ... 5] of integer;

    begin

    randomize;

    for i : = 2 to 5 do

    o[i] : = 0;

    for i : = 1 to N do

    begin

    a : = 2 + random (4) ;

    o[a] : = o[a] + 1;

    end;

    for i : = 2 to 5 do

    writeln (i,'=', o[i]) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу. Группа студентов сдает экзамен. оценки формируются случайным образом от 2 до 5. Напечатать кол-во полученых двок, трок, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы