Задать вопрос
22 июня, 02:17

Помогите написать программу в паскаль АBC задание:

Напишите программу которая в последовательности натуральных чисел определяет чётное минимальное число. При этом кол-во введённых чисел неизвестно. Но не превышает 1000. Введённые числа не превышают 30000. В последовательности всегда имеется чётное число. Программа должна вывести это одно минимальное чётное число.

+1
Ответы (1)
  1. 22 июня, 04:38
    0
    Var N, A, Min:integer;

    Begin

    Min:=30001;

    Read (N) ;

    For N: = 1 to N do

    Begin

    Read (A) ;

    if (A mod 2 = 0) and (A < Min) then Min:=A;

    End;

    WriteLn (Min)

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите написать программу в паскаль АBC задание: Напишите программу которая в последовательности натуральных чисел определяет чётное ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы