Задать вопрос
22 марта, 19:49

Напишите программу, которая считывает с клавиатуры строку S и определяет, встречаются ли в строке S слова палиндромы. Словом считается последовательность символов, ограниченная проьелами, и не имеющая пробелов внутри себя. Строка S не пустая, содержит не более 200 символов и состоит только из строчных и прописных букв латинского алфавита и пробелов

+3
Ответы (1)
  1. 22 марта, 22:57
    0
    Var

    s, t:string;

    n, i:integer;

    begin

    write ('Введите строку: ') ;

    readln (t) ;

    n:=1;

    t:=t+' ';

    for i:=2 to length (t) do

    if ((t[i]=' ') or (i=length (t))) and (i-n>1) then

    begin

    s:=Copy (t, n, i-n) ;

    if s=ReverseString (s) then

    begin

    writeln ('Да, палиндромы есть') ;

    halt

    end

    else n:=i+1

    end;

    writeln ('Палиндромов нет')

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая считывает с клавиатуры строку S и определяет, встречаются ли в строке S слова палиндромы. Словом считается ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы