Задать вопрос
6 октября, 19:22

Помогите составить программу ... вот она. Даны К и массив Т (к). Найти сумму и количество элементов в массиве Т после первого нулевого элемента.

+2
Ответы (1)
  1. 6 октября, 21:36
    0
    Const kmax = 20;

    var T:array [1 ... kmax] of integer;

    i, k, zero, sum, count:integer;

    begin

    count:=0;

    sum:=0;

    repeat

    write ('K (K<20) = ') ;

    readln (k) ;

    until k in [1 ... kmax];

    randomize;

    for i:=1 to k do

    begin

    T[i]:=random (14) - 5;

    write (T[i]:3) ;

    end;

    writeln;

    zero:=1;

    while (zero<=k) and (T[zero]0) do inc (zero) ;

    count:=k-zero;

    if zerokmax then

    for i:=zero+1 to k do sum:=sum+T[i];

    writeln ('Summa: ', sum) ;

    writeln ('Kol-vo: ', count) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите составить программу ... вот она. Даны К и массив Т (к). Найти сумму и количество элементов в массиве Т после первого нулевого ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы