Задать вопрос
4 июля, 18:20

Составьте программу произведения первой и третьей и суммы второй и четвертой цифры четырехзначного числа

(Паскаль)

+5
Ответы (2)
  1. 4 июля, 18:42
    0
    Program programma;

    var a, b, c, d, e, p, s: integer;

    begin

    writeln ('Введите четырехзначное число') ;

    readln (a) ;

    b:=a div 1000;

    c:=a div 100;

    c:=c mod 10;

    d:=a mod 100;

    d:=d div 10;

    e:=a mod 10;

    p:=b*d;

    s:=c+e;

    writeln ('Произведение первой и третьей цифры равно ', p,', сумма второй и четвертой цифры равна ', s) ;

    end.
  2. 4 июля, 19:22
    0
    Program zadacha;

    var

    a, p, s:integer;

    begin

    writeln ('Введите четырехзначное число') ;

    readln (a) ;

    p: = (a div 1000) * (a mod 100 div 10) ;

    s: = (a div 100 mod 10) + (a mod 10) ;

    writeln ('Произведение первой и третьей = ', p) ;

    writeln ('Сумма второй и четвертой = ', s)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу произведения первой и третьей и суммы второй и четвертой цифры четырехзначного числа (Паскаль) ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr (x) + x/3+sqr (sin (x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3:
Ответы (1)
Напишите программу на языке Паскаль, для решения следующей задачи: Для любого четырехзначного вводимого числа найти сумму второй и предпоследней цифры). (Подсказка. Используйте тип данных integer и операции div и mod)
Ответы (2)
Дано четырехзначное число если сумма всех цифр кратно 5 ти найти корень квадратный от произведения первой и четвертой цифры иначе найти произведение второй и третьей цифры
Ответы (1)