Задать вопрос
26 июля, 22:22

Задача №334. Остаток

Входные данные

Вводятся 4 числа: a, b, c и d.

Выходные данные

Выведите все числа на отрезке от a до b, дающие остаток c при делении на d. Если таких чисел не существует, то ничего выводить не нужно.

Примеры

входные данные

2

5

0

2

выходные данные

2 4

входные данные

2

7

9

14

выходные данные

+2
Ответы (1)
  1. 27 июля, 01:43
    0
    Var

    a, b, c, d, x:integer;

    begin

    read (a, b, c, d) ;

    for x: = a to b do

    if x mod d = c then

    write (x,' ') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Задача №334. Остаток Входные данные Вводятся 4 числа: a, b, c и d. Выходные данные Выведите все числа на отрезке от a до b, дающие остаток ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы