Задать вопрос
20 января, 02:15

Составить программу для решения задачи. Найти сумму всех положительных элементов массива, состоящего из семи элементов.

+2
Ответы (1)
  1. 20 января, 05:23
    0
    var

    i, s:integer;

    a: array [ 1 ... 7 ] of integer;

    begin

    for i:=1 to 7 do

    begin

    writeln ('Введите эл. массива A[', i, ']') ;

    readln (A[i]) ;

    end;

    for i:=1 to 7 do

    if a[i]>0 then s:=s+a[i];

    writeln ('Сумма всех положительных элементов массива: ', s) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу для решения задачи. Найти сумму всех положительных элементов массива, состоящего из семи элементов. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы