Задать вопрос
7 ноября, 08:46

Дан массив из N элементов. Составить программу, сортирующую по возрастанию все числа с нечётными индексами в массиве.

+3
Ответы (1)
  1. 7 ноября, 09:38
    0
    var

    a: array [1 ... 100] of integer;

    i, j, n, k: integer;

    begin

    readln (n) ;

    for i: = 1 to n do readln (a[i]) ;

    for i: = 1 to n do if Odd (i) then

    for j: = 1 to n-i do if Odd (j) then

    if a[j]>a[j+2] then begin

    k: = a[j];

    a[j]: = a[j+2];

    a[j+2]: = k

    end;

    for i: = 1 to n do write (a[i],' ')

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дан массив из N элементов. Составить программу, сортирующую по возрастанию все числа с нечётными индексами в массиве. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы