Задать вопрос
3 марта, 23:44

Дано целое положительное трехзначное число n. Составить программу, которая определяет входит ли в него цифра 8.

+5
Ответы (1)
  1. 4 марта, 02:19
    0
    Var n:integer;

    Begin

    Write ('Введите трёхзначное число: ') ; ReadLn (n) ;

    n:=Abs (n) ;

    if (n div 100 = 8) or ((n div 10) mod 10 = 8) or (n mod 10 = 8) then WriteLn ('Входит')

    else WriteLn ('Не входит')

    End.

    Пример работы программы:

    Введите трёхзначное число: 85

    Входит
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дано целое положительное трехзначное число n. Составить программу, которая определяет входит ли в него цифра 8. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы