Задать вопрос
19 июня, 18:17

Паскаль. 1) Определите, сколько чисел, введённых пользователем делятся на 3 без остатка. Ввод чисел пользователем заканчивается после ввода цифры 0. 2) Найдите сумму цифр числа, меньших 5. Например, для числа 715245 это будет 1+2+4=7. Написать блок-схему и программу.

+5
Ответы (2)
  1. 19 июня, 21:05
    0
    var

    C, count:integer;

    begin

    write ('Введите число ') ;

    count : = 0;

    readln (C) ;

    while C 0 do

    begin

    if (C mod 3) = 0 then

    inc (count) ;

    write ('Введите число ') ;

    readln (C) ;

    end;

    writeln ('Count = ', count) ;

    readln;

    end.

    //вторая программа

    var

    C, Summ:integer;

    begin

    write ('C = ') ;

    Summ : = 0;

    readln (C) ;

    while C 0 do

    begin

    if (C mod 10) < 5 then

    inc (Summ, C mod 10) ;

    C : = C div 10;

    end;

    writeln ('Summ = ', Summ) ;

    readln;

    end.
  2. 19 июня, 21:39
    0
    1)

    program ABC;

    var num, count:integer;

    begin

    readln (num) ;

    while num0 do

    begin

    if (num mod 3) = 3 then

    count:=count+1

    end;

    writeln (count)

    end.

    2)

    program ABC;

    var num, sum:integer;

    begin

    readln (num) ;

    while num0 do

    begin

    if (num mod 10) < 5 then

    sum:=sum+num mod 10;

    num: = num div 10

    end;

    writeln (sum)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Паскаль. 1) Определите, сколько чисел, введённых пользователем делятся на 3 без остатка. Ввод чисел пользователем заканчивается после ввода ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы