Задать вопрос
22 апреля, 12:50

Задача №308. Исключающее ИЛИ

Напишите функцию

function _Xor (x, y:boolean) : boolean (Pascal)

Входные данные

Вводится 2 числа - x и y (x и y равны 0 или 1, 0 соответствует значению false, 1 соответствует значению true).

Выходные данные

Необходимо вывести 0 или 1 - значение функции от x и y.

выодные 0 1 выходные 1

Хелп

+5
Ответы (1)
  1. 22 апреля, 15:48
    0
    Function _Xor (x, y:boolean) : boolean;

    begin

    _Xor:=not (x=y) ;

    end;

    var x, y:integer;

    begin

    write ('x y: ') ;

    readln (x, y) ;

    if _Xor (x=0, y=0)

    then writeln (1) else writeln (0) ;

    end.

    Пример:

    x y: 0 1

    1
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Задача №308. Исключающее ИЛИ Напишите функцию function _Xor (x, y:boolean) : boolean (Pascal) Входные данные Вводится 2 числа - x и y (x и ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы