Задать вопрос
29 апреля, 18:58

Напишите программу вычисления наименьшего общего кратного следующих четырех чисел: 36 54 18 и 15. Используйте процедуру вычисления общего делителя двух чисел

+1
Ответы (1)
  1. 29 апреля, 22:50
    0
    Var

    A:array[1 ... 4] of integer;

    i, j, R, P:integer;

    function HOD (c, b:integer) : integer;

    begin

    while cb do

    if c>b

    then

    c:=c-b

    else

    b:=b-c;

    HOD:=c;

    end;

    function HOK (c, b, RR:integer) : integer;

    begin

    if ((c mod b=0) or (b mod c=0)) and ((c div b > 1) or (b div c > 1))

    then

    begin

    if c>b

    then

    HoK:=c

    else

    HOK:=b;

    end

    else

    HOK: = (c*b) div RR;

    end;

    begin

    A[1]:=36;

    A[2]:=54;

    A[3]:=18;

    A[4]:=15;

    P:=1;

    R:=HOD (A[1], A[2]) ;

    P:=HOK (A[1], A[2], R) ;

    for i:=3 to 4 do

    begin

    R:=HOD (R, A[i]) ;

    P:=HOK (P, A[i], R) ;

    end; writeln ('HOK = ', P) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу вычисления наименьшего общего кратного следующих четырех чисел: 36 54 18 и 15. Используйте процедуру вычисления общего ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы