Задать вопрос
20 сентября, 04:04

Напишите программу

Определить кол-во и сумму четных чисел. Последовательность чисел оканчивантся 0. Программа должна вывести 2 числа, первое: длину, последовательность, второе число: сумму четных чисел

Числа при вводе 4,60,15,0

+3
Ответы (1)
  1. 20 сентября, 04:54
    0
    Program n1;

    var a, k, sum: integer;

    begin

    readln (a) ;

    k:=0;

    sum:=0;

    while a0 do

    begin

    if (a mod 2=0) then sum:=sum+a;

    k:=k+1;

    readln (a) ;

    end;

    writeln (k) ;

    writeln (sum) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу Определить кол-во и сумму четных чисел. Последовательность чисел оканчивантся 0. Программа должна вывести 2 числа, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы