Задать вопрос
30 декабря, 02:31

Реализуйте рекурсивную функцию вычисления факториала натурального числа.

Напоминаем, что факториалом числа называется произведение всех натуральных чисел, меньших или равных ему. К примеру, факториал 55 равен 5⋅4⋅3⋅2⋅15⋅4⋅3⋅2⋅1.

Формат входных данных

На вход ваша программа получает одно число - n (1≤n≤8) (1≤n≤8).

Формат выходных данных

Выведите одно число - факториал числа n.

+1
Ответы (2)
  1. 30 декабря, 03:50
    0
    Var n:integer;

    function fact (n:integer) : longint;

    begin

    if n=1

    then fact:=1

    else fact:=n*fact (n-1) ;

    end;

    begin

    write ('n = ') ;

    readln (n) ;

    writeln (n,'! = ', fact (n)) ;

    end.

    Пример:

    n = 6

    6! = 720
  2. 30 декабря, 06:00
    0
    Var n: int64;

    function f (n: int64) : int64;

    begin

    if (n = 1) then f : = 1

    else f : = f (n - 1) * n;

    end;

    begin

    readln (n) ;

    write (f (n)) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Реализуйте рекурсивную функцию вычисления факториала натурального числа. Напоминаем, что факториалом числа называется произведение всех ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы