Задать вопрос
26 декабря, 07:08

Вам дана строка S. Надо определить, сколько в ней цифр

Формат входных данных

Единственная строка входного файла содержит строку S, которая может состоять из букв английского алфавита и цифр.

Гарантируется, что строка не пустая и ее длина не превосходит 100

Формат выходных данных

Выведите ответ к задаче

+5
Ответы (2)
  1. 26 декабря, 07:27
    0
    Var

    s: string;

    k, i: integer;

    begin

    read (s) ;

    for i : = 1 to length (s) do

    if (s[i] in ['0' ... '9']) then

    k : = K + 1;

    writeln (k) ;

    end.
  2. 26 декабря, 10:01
    0
    Program Task;

    Var S: String;

    i, nums: Integer;

    Begin

    WriteLn ('Введите строку') ;

    ReadLn (S) ;

    If Length (S) > 100 Then

    WriteLn ('Ошибка. Завершение работы программы') ;

    For i : = 1 To Length (S) Do

    If (Ord (S[i]) > = 48) And (Ord (S[i]) < = 57) Then

    nums : = nums + 1;

    WriteLn ('Количество цифр в строке: ', nums) ;

    ReadLn;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Вам дана строка S. Надо определить, сколько в ней цифр Формат входных данных Единственная строка входного файла содержит строку S, которая ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы