Задать вопрос
15 октября, 08:22

Белки спрятали в дупле N орехов. Каждый день они брали половину для себя и своих друзей. Если число орехов было нечетным, то они откладывали один орех в сторону, а остальные делили пополам, причём отложенный орех опять возвращали в дупло. Напишите программу, подсчитывающую, сколько орехов останется в мешке через К дней?

+5
Ответы (1)
  1. 15 октября, 09:47
    0
    Var n, k, m, i:integer;

    begin

    write ('n = ') ;

    readln (n) ;

    write ('k = ') ;

    readln (k) ;

    m:=n;

    for i:=1 to k do

    m: = (m div 2) + (m mod 2) ;

    writeln ('m = ', m) ;

    end.

    Пример:

    n = 1000

    k = 5

    m = 32
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Белки спрятали в дупле N орехов. Каждый день они брали половину для себя и своих друзей. Если число орехов было нечетным, то они ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы