Задать вопрос
26 марта, 05:45

1) Требовалось написать программу, 1) Требовалось написать программу, которая определяет, можно ли построить треугольник из отрезков с длинами х, у, z. Программа должна выводить соответствующее текстовое сообщение. Программист сделал в программе ошибки.

var х, у, z: real;

begin

readln (x, у, z) ;

if (x + y > z) then

begin

if (x + z > y) then i

f (y + z > x) then

writeln ('треугольник построить можно') ;

end

else writeln ('треугольник построить нельзя') ;

end

Последовательно выполните задания: 1. Приведите пример таких чисел х, у, z, при которых программа неверно решает поставленную задачу. 2. Укажите, как нужно доработать программу, чтобы не было случаев ее неправильной работы (можно указать один из способов доработки исходной программы). 3. Укажите, как можно доработать программу, чтобы она вместо вложенных операторов IF содержала логическую операцию AND.

+3
Ответы (1)
  1. 26 марта, 08:04
    0
    1: 10, 1, 1

    2: var

    x, y, z: real;

    begin

    readln (x, y, z) ;

    if (x + y > z) then

    begin

    if (x + z > y) then

    if (y + z > x) then

    writeln ('треугольник построить можно')

    else writeln ('треугольник построить нельзя') ;

    end

    else writeln ('треугольник построить нельзя') ;

    end.

    3:

    var

    x, y, z: real;

    begin

    readln (x, y, z) ;

    if (x + y > z) and (x + z > y) and (y + z > x) then

    writeln ('треугольник построить можно')

    else writeln (' треугольник построить нельзя ') ;

    end.

    вроде все пашет так)))
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1) Требовалось написать программу, 1) Требовалось написать программу, которая определяет, можно ли построить треугольник из отрезков с ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы