Задать вопрос
5 ноября, 19:14

на паскале составить программу нахождения количества отрицательных элементов в заданном массиве из 10 действительных чисел

+5
Ответы (2)
  1. 5 ноября, 19:32
    0
    Var a, i:integer;

    var arrayx = array[0 ... 10] of integer;

    begin

    arrayx[0] = - 1;

    arrayx[1] = 3;

    arrayx[2] = 5;

    arrayx[3] = - 3;

    arrayx[4] = - 2;

    arrayx[5] = - 7;

    arrayx[6] = 2;

    arrayx[7] = 3;

    arrayx[8] = - 10;

    arrayx[9] = 0;

    for i : = 1 to 10 do

    begin

    if (arrayx[i] < 0) a: = a + 1;

    end;

    writeln ("Отрицательных чисел: ", a) ;

    readln;

    end.
  2. 5 ноября, 22:58
    0
    Program test;

    const n = 10;

    var i, k:integer;

    m: array[1 ... n] of integer;

    begin

    for i:=1 to n do

    begin

    write (' Введите [', i,'] член масива: ') ;

    readln (m[i]) ;

    end;

    for i:=1 to n do if m[i]<0 then inc (k) ;

    writeln ('Количество чисел меньших нуля : ', k) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «на паскале составить программу нахождения количества отрицательных элементов в заданном массиве из 10 действительных чисел ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы