Задать вопрос
29 ноября, 17:33

Яблочки Ограничение времени 2 секунды

Ограничение памяти 64Mb

Ввод стандартный ввод или input. txt

Вывод стандартный вывод или output. txt После очередного успеха на олимпиаде Никита и Кирилл решили открыть собственный бизнес. Бизнес не простой, а золотой - продажа яблок сорта Golden. Миллионер Семён решил порадовать любимую мамочку - купить ей вкусных яблок. Он пришёл на импровизированный рынок НиК, где работали Никита и Кирилл. Семён решил купить все яблоки, благо денег у него хватает. Продав все яблоки, Никита и Кирилл стали считать прибыль. Известно, что Никита продал A яблок по M тугриков, а Кирилл продал B яблок по N тугриков. К сожалению, с математикой у ребят плохо, поэтому они хотят узнать у вас, кто же получил бОльшую прибыль. Формат вводаФормат выводаВыведите единственное целое число - заработок продавца, получившего бОльшую прибыль. Пример

Ввод Вывод

8 2 2 3 16

+3
Ответы (1)
  1. 29 ноября, 20:50
    0
    Для начала создайте файл типа блокнот (расширение. txt) под названием input. Файл output создастся автоматически. Program apple; Uses crt; Var a, b, m, n: integer; f1, f2: text; Begin Assign (f1, 'input. txt') ; Assign (f2, 'output. txt') ; Reset (f1) ; Rewrite (f2) ; Readln (a, m, b, n) ; If a*m>b*n then Writeln (f2, a*m) Else writeln (f2, b*n) ; Close (f1) ; Close (f2) ; End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Яблочки Ограничение времени 2 секунды Ограничение памяти 64Mb Ввод стандартный ввод или input. txt Вывод стандартный вывод или output. txt ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы