Задать вопрос
22 марта, 08:26

Написать программу, которая вводит n элементов массива и вычисляет сумму первого и максимального элемента массива

+2
Ответы (2)
  1. 22 марта, 08:54
    0
    uses crt;

    var

    a:array [1 ... 1000] of integer;

    max, i, k:integer;

    begin

    write ('Введи количество элементов массива: ') ; read (k) ;

    for i:=1 to k do

    begin

    a[i]:=random (100) - 50;

    write (a[i]:4) ;

    end;

    writeln;

    max: = a[1];

    for i:=1 to k do

    if a[i]>max then max:=a[i];

    writeln ('Максимальный элемент: ', max) ;

    writeln ('Сумма первого и максимального элементов: ', max+a[1])

    end.
  2. 22 марта, 09:19
    0
    Случайным образом вводятся целые числа от 0 до 999.

    max - максимальный элемент массива

    i - цикловая переменная.

    var

    a : array [1 ... 100] of integer;

    max, i, n : integer;

    begin

    readln (n) ;

    for i : = 1 to n do

    a [ i ] : = random (1000) ;

    max : = a [ 1 ];

    for i : = 2 to n do

    if a [ i ] > max then

    max : = a [ i ];

    writeln (max + a [ 1 ])

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, которая вводит n элементов массива и вычисляет сумму первого и максимального элемента массива ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы