Задать вопрос
12 января, 09:34

Студент зa лето заработал C РУб. Ежемесячная стипендия студента составляет А руб, расходы на проживание - В руб. (А<В). Рост цен ежемесячно увеличивает

расходы на проживание на 3%. Написать программу, определяющую, на сколько месяцев хватит денег. Задача в Паскале

+1
Ответы (1)
  1. 12 января, 11:48
    0
    Var A, B, C : real;

    time : integer;

    begin

    Writeln ('сколько заработал за лето') ;

    readln (c) ;

    Writeln ('стипендия = ') ;

    readln (A) ;

    Writeln ('расходы на проживание') ;

    Readln (b) ;

    C:=c+a-b;

    while (c>=0) do begin

    C:=c+a-b;

    b:=b + (b/100*3) ;

    time:=time+1;

    end;

    writeln ('денег хватит на ', time,' месяцев') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Студент зa лето заработал C РУб. Ежемесячная стипендия студента составляет А руб, расходы на проживание - В руб. (А ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы