Задать вопрос
12 ноября, 17:31

Напишите программу, которая выводит последнее слово переданной её символьной строки. Слово - это последовательность непробельных символов, ограниченная пробелами или концами строки.

Входные данные

Входная строка содержит произвольную последовательность символов.

Выходные данные

Программа должна вывести последнее слово этой строки.

Примеры

входные данные

Abra babra cadabra

выходные данные

cadabra

+1
Ответы (1)
  1. 12 ноября, 17:44
    0
    Program z1; Var i, b, j, n:integer; s, space, h:string; a: array [1 ... 1000] of string; Begin write ('Введите текст - ') ; readln (s) ; b:=length (s) ; space:=' '; i:=1; n:=0; j:=1; while i<=b do begin h:=''; while s[i]space do begin h:=h+s[i]; i:=i+1; end; a[j]:=h; j:=j+1; i:=i+1; n:=n+1; end; write (a[n],' ') ; End. Только в конце предложения ставь тоже пробел!
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая выводит последнее слово переданной её символьной строки. Слово - это последовательность непробельных символов, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы