Задать вопрос
4 мая, 05:32

Написать программу поиска номера элемента массива, принадлежащего заданному промежутку [1, 5], используя линейный поиск. Решить на Pascal ABC.

Пример: Линейный поиск элементов массива:

procedure poisk (z:omas; x:integer) ;

var i, p:byte;

begin

for i:=1 to n do

begin

if z[i]=x then p:=i;

end;

end;

+4
Ответы (1)
  1. 4 мая, 05:44
    0
    Const n = 5;

    var

    i, p, x:byte;

    z: array[1 ... n] of byte;

    begin

    readln (x) ;

    for i:=1 to n do

    begin

    readln (z[i]) ;

    if z[i]=x then p:=i;

    end;

    writeln (p) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу поиска номера элемента массива, принадлежащего заданному промежутку [1, 5], используя линейный поиск. Решить на Pascal ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы