Задать вопрос
30 декабря, 15:06

Вычислите n-й член последовательности, заданной формулами: a2n = an + an-1, a2n+1 = an - an-1, a0 = a1 = 1. Входные данные Вводится одно натуральное число n (1≤n≤1000). Выходные данные Вывести одно число an.

+2
Ответы (1)
  1. 30 декабря, 15:35
    0
    Var i, n, k: integer;

    a: array[0 ... 1000] of integer;

    begin

    write ('n = ') ; readln (n) ;

    a[0]:=1; a[1]:=1;

    i:=2;

    repeat

    k:=i div 2;

    if (i mod 2) = 0 then a[i]:=a[k]+a[k-1]

    else a[i]:=a[k]-a[k-1];

    i:=i+1;

    until i>n;

    writeln ('a (n) = ', a[n]) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Вычислите n-й член последовательности, заданной формулами: a2n = an + an-1, a2n+1 = an - an-1, a0 = a1 = 1. Входные данные Вводится одно ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы