Задать вопрос
19 ноября, 11:10

помогите решить Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 6. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 6. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число - сумму чисел, кратных 6. Пример работы программы: Входные данные Выходные данные 3 12 25 6 18 20.2

+5
Ответы (1)
  1. 19 ноября, 13:28
    0
    uses crt;

    var i, ch, s, n:integer;

    begin

    s:=0;

    readln (n) ;

    for i:=1 to n do

    begin

    readln (ch) ;

    if ch<301 then

    begin

    if ch mod 6 = 0 then s:=s+ch;

    end else begin writeln ('error') ; break; end;

    end;

    writeln;

    writeln (s) ;

    readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «помогите решить Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 6. Программа получает на ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы