Задать вопрос
25 ноября, 07:39

Задан двумерный массив, имеющий N строк и M столбцов. Определите, является ли строка номер N1 равной строке номер N2. Если ДА - вывести Yes и сумму элементов строки N1. Если НЕТ - вывести No и сумму элементов строки N2.

Формат ввода:

N M (N<=10, M<=12)

a[1,1] a[1,2] ... a[1, M]

a[2,1] a[2,2] ... a[2, M]

...

a[N, 1] a[N, 2] ... a[N, M]

N1 N2

Пример ввода:

3 4

1 2 3 4

1 2 3 4

1 2 4 4

1 2

Пример ввода:

3 4

1 2 3 4

1 2 3 5

1 2 3 4

1 2

Формат вывода:

Yes SumN1

или

No SumN2

Пример вывода:

Yes 10

Пример вывода:

No 11

SumN1 - сумма всех элементов строки N1

SumN2 - сумма всех элементов строки N2

+1
Ответы (1)
  1. 25 ноября, 08:00
    0
    Var a:array[1 ... 10,1 ... 12] of integer;

    n, m, n1, n2, i, j, s1, s2:integer;

    b:boolean;

    begin

    readln (n, m) ;

    for i:=1 to n do

    for j:=1 to m do read (a[i, j]) ;

    readln (n1, n2) ;

    s1:=0; s2:=0; b:=true;

    for j:=1 to m do

    begin

    s1:=s1+a[n1, j]; s2:=s2+a[n2, j];

    if a[n1, j]a[n2, j] then b:=false;

    end;

    if b then write ('YES, s1 = ', s1) else write ('NO, s2 = ', s2) ;

    end.

    Пример:

    3 4

    1 2 3 4

    2 3 1 4

    1 2 3 4

    1 3

    YES, s1 = 10
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Задан двумерный массив, имеющий N строк и M столбцов. Определите, является ли строка номер N1 равной строке номер N2. Если ДА - вывести Yes ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы