Задать вопрос
19 декабря, 07:08

Написать программу, которая после ввода пользователем трёхзначного числа вычисляет сумму его цифр.

+1
Ответы (1)
  1. 19 декабря, 09:40
    0
    var a, a1, a2, a3 : integer;

    begin

    readln (a) ;

    a1:=a div 100;

    a2: = (a mod 100) div 10;

    a3: = (a mod 100) mod 10;

    writeln (a1+a2+a3) ;

    end.

    а - само число, а1-число сотен, а2-число десятков, а3-число единиц
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, которая после ввода пользователем трёхзначного числа вычисляет сумму его цифр. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы