Задать вопрос
20 июля, 20:50

Опишите множества D1, D2, D3. Заполните их соответственно числами 2,4,6,8; 0,1,2,3,5; 1,3,5,7,9. Выполните над множествами операции объединения, разности и пересечения.

+2
Ответы (1)
  1. 20 июля, 21:15
    0
    Program Dafnochka;

    uses crt;

    type

    TypeD=set of 0 ... 10;

    var

    dr, d1, d2, d3:TypeD;

    c:integer;

    begin

    d1:=[2,4,6,8];

    d2:=[0,1,2,3,5];

    d3:=[1,3,5,7,9];

    {вывод множеств}

    writeln ('Множество D1:') ;

    for c:=0 to 10 do

    if c in d1 then

    write (' ', c,' ') ;

    writeln () ;

    writeln () ;

    writeln ('Множество D2:') ;

    for c:=0 to 10 do

    if c in d2 then

    write (' ', c,' ') ;

    writeln () ;

    writeln () ;

    writeln ('Множество D3:') ;

    for c:=0 to 10 do

    if c in d3 then

    write (' ', c,' ') ;

    writeln () ;

    writeln () ;

    {примеры}

    dr:=d1+d2;

    writeln ('Пример 1 - объединение множеств D1 U D2') ;

    for c:=0 to 10 do

    if c in dr then

    write (' ', c,' ') ;

    writeln () ;

    dr:=d2-d3;

    writeln () ;

    writeln ('Пример 2 - разность множеств D2/D3') ;

    for c:=0 to 10 do

    if c in dr then

    write (' ', c,' ') ;

    writeln () ;

    dr:=d2*d3;

    writeln () ;

    writeln ('Пример 3 - пересечение множеств D2 П D3') ;

    for c:=0 to 10 do

    if c in dr then

    write (' ', c,' ') ;

    writeln () ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Опишите множества D1, D2, D3. Заполните их соответственно числами 2,4,6,8; 0,1,2,3,5; 1,3,5,7,9. Выполните над множествами операции ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Пусть есть высказывание А есть: "Множество А есть подмножество множества В ", высказывание В есть: "Все элементы множества А являются элементами множества В".
Ответы (1)
Приведите примеры: а) пустого множества; б) множества, состоящего из одного элемента; в) множества, состоящего из 10 элементов; г) бесконечного множества.
Ответы (1)
Составить программу - калькулятор, которая запрашивает тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, а также два числа и производит над ними соответствующую арифметическую операцию.
Ответы (1)
1. Заполните массив случайными числами в диапазоне 20 ... 100 и подсчитайте отдельно число чётных и нечётных элементов (Программа Питон) 2. Заполните массив случайными числами в диапазоне 1000 ...
Ответы (1)
В программе обозначает оператор присваивание знаки и > - соответственно операции сложение вычитание умножения и деления правило выполнения операции и порядок действии соответствют правилам арифметики опредилите значение переменной а
Ответы (1)