Задать вопрос
3 октября, 15:50

Напишите программу поиска всех четырёхзначных чисел, у которых все четыре цифры различны.

+3
Ответы (1)
  1. 3 октября, 19:21
    0
    Var i, a, b, c, d, temp:integer;

    begin

    for i:=1000 to 9999 do

    begin

    temp:=i

    a:=temp div 1000;

    temp: = temp mod 1000;

    b:=temp div 100;

    temp: = temp mod 100;

    c:=temp div 10;

    d: = temp mod 10;

    if (ab) and (ac) and (ad) and (bc) and (bd) and (cd) then writeln (i) ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу поиска всех четырёхзначных чисел, у которых все четыре цифры различны. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы