Задать вопрос
22 июля, 21:04

Написать программу для Паскаль

Найдите среднюю температуру для дней, когда температура поднималась выше 0 градусов, и определите количество таких дней. Программа получает на входе количество дней, в течение которых проводилось наблюдение, затем для каждого дня вводится температура.

+4
Ответы (1)
  1. 22 июля, 23:53
    0
    var

    m, k, d1: single;

    i, t, d: byte;

    begin

    readln (t) ;

    writeln () ;

    for i : = 1 to t do

    begin

    readln (k) ;

    if (k > 0) then

    begin

    d1 + = k;

    d + = 1;

    end;

    end;

    writeln (d1 / d) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу для Паскаль Найдите среднюю температуру для дней, когда температура поднималась выше 0 градусов, и определите количество ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы