Задать вопрос
6 августа, 11:35

1 задача.

Сколько существует целых

положительных чисел, меньших 512₁₀,

в двоичной записи которых

встречается не менее шести единиц подряд?

В ответе укажите целое число.

2. задача. Модему, передающему информацию со

скоростью 512 байт/c,

потребовалось

1 минута и 4 секунды для того, чтобы передать растровое

изображение. Укажите максимальное количество цветов в палитре изображения, если

известно, что его размер составил 128x256 пикселей. Ответ запишите в виде

целого числа.

+4
Ответы (1)
  1. 6 августа, 15:16
    0
    Program gt;

    var a:array[1 ... 100]of integer;

    k, q, p, i, max:integer;

    begin

    for i:=1 to 512 do

    begin

    p:=i;

    max:=0;

    K:=0;

    while p>0 do

    begin

    q:=p mod 2;

    p:=p div 2;

    if (q=1) then k:=k+1;

    if (q=0) then begin

    if (k>max) then max:=k;

    k:=0;

    end;

    end;

    if (max>=6) then writeln (i) ;

    end;

    end.

    191

    319

    382

    383

    447

    2)

    размер 512 байт / c*64c = 32768 байт

    в изображении - 32768 пикселей

    значит на пиксель отведен 1 байт памяти или 8 бит значит палитра 2^8 цветов или 256
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1 задача. Сколько существует целых положительных чисел, меньших 512₁₀, в двоичной записи которых встречается не менее шести единиц подряд? ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы