Задать вопрос
17 сентября, 21:43

Написать программу которая из двух строк составляет третью, путём чередования символов первой и второй строки.

+4
Ответы (1)
  1. 17 сентября, 22:52
    0
    program tref;

    var a1, a2, a3:string; i, c, b, j, a:integer;

    begin

    a:=1;

    b:=1;

    readln (a1) ;

    readln (a2) ;

    a3:=a1+a2; for i:=1 to length (a1) * 2 do

    begin

    if (i mod 2 = 1) then

    begin

    a3[i]:=a1[b];

    b:=b+1; end;;

    if (i mod 2 = 0) then

    begin

    a3[i]:=a2[a];

    a:=a+1;

    end;

    end;

    writeln (a3) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу которая из двух строк составляет третью, путём чередования символов первой и второй строки. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы