Задать вопрос
24 мая, 08:15

Составьте программу, которая выводит на экран число сотен в заданном числе, если оно трёхзначное, а в противном случае сообщает: "число не трёхзначное".

+3
Ответы (1)
  1. 24 мая, 09:44
    0
    Решение на С/C + +:

    #include

    using namespace std;

    int main ()

    {

    int number;

    cin>>number;

    number = (number-number%10) / 10;

    //в результате остаётся число десятков, т. е. число без единиц

    number = (number-number%10) / 10; / / тут уже число сотен без десятков

    if (number==0) / / если в результате будет 0 десятков, то выводим текст

    {

    cout<<"chislo ne trehznachnoe";

    }

    else / / в противном случае десятки будут

    {

    cout<
    }

    return 0;

    }
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу, которая выводит на экран число сотен в заданном числе, если оно трёхзначное, а в противном случае сообщает: "число не ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы