Задать вопрос
9 октября, 15:53

Написать программу (Процедуру), выводящую квадраты чисел от a до b (a, b вводятся с клавиатуры) ;

+3
Ответы (1)
  1. 9 октября, 18:41
    0
    И всё-таки, мне кажется, что надо вывести именно полные квадраты чисел в указанном диапазоне, иначе формулировка была бы типа: "Возведите в квадрат все числа в указанном диапазоне". Код на паскале:

    var a, b, i, j : integer;

    begin

    readln (a, b) ;

    for i : = a to b do

    begin

    j : = round (sqrt (i)) ;

    if j*j = i then writeln (i) ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу (Процедуру), выводящую квадраты чисел от a до b (a, b вводятся с клавиатуры) ; ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы