Задать вопрос
1 января, 17:48

Нужна помощь: Составить программу по которой компьютер угадает число введеное с клавиатуры (с помощью repeat), с пояснениями (игра похожа на игру угадай число, но угадывает компьютер, а мы задумываем)

+3
Ответы (1)
  1. 1 января, 21:29
    0
    var x, y, a:integer;

    c:boolean;

    begin

    readln (x) ; {считываем}

    a:=1;

    repeat

    writeln (a,' попытка выбор компьютера пал на - ') ;

    y:=random (x) + 1; {задаем промежуток рандомом}

    write (y) ;

    if x=y {сравниваем} then c:=true; {выходим из цикла в случае успеха}

    until c; {если с=true тогда выход из цикла, иначе крутимся дальше}

    writeln ('Компьютер сделал ', a,' попыток.') ;

    end.

    Более доработанная и понятная, если возникают какие-то вопросы - пиши в личку.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Нужна помощь: Составить программу по которой компьютер угадает число введеное с клавиатуры (с помощью repeat), с пояснениями (игра похожа ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы