Задать вопрос
2 февраля, 19:33

Составьте программу которая выводит только те числа котрые делятся на 7

+2
Ответы (1)
  1. 2 февраля, 21:50
    0
    Возможно нерационально но, пусть. Сначала вы вводите количество чисел, потом сами числа. Если число делится на 7 - то будет соответствующая строка, после чего будет предложено ввести новое число; Если нет, то будет предложено ввести новое число.

    program cv;

    var

    a, i, chislo:integer;

    begin

    writeln ('Введите количество чисел') ;

    readln (a) ;

    for i:=1 to a do

    begin

    writeln ('Введите число') ;

    readln (chislo) ;

    if (chislo mod 7=0) then writeln ('Число ', chislo,' делится на 7.')

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу которая выводит только те числа котрые делятся на 7 ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы